Print Page | Close Window

Speech recognition functionality in games question

Printed From: MSSpeech-Forum
Category: Windows™ Speech Recognition Forums
Forum Name: New Users & General Questions
Forum Description: Ask questions, give and get answers.
Printed Date: 22/Sep/2020 at 8:55pm
Software Version: Web Wiz Forums 12.02 -

Topic: Speech recognition functionality in games question
Posted By: Sanjiyan
Subject: Speech recognition functionality in games question
Date Posted: 11/Mar/2016 at 10:21am

So I’ve recently decided to try and see if I could get WSR to work in online games for the chat windows.  I just set it up a few days ago, running on Windows 7 and also installed the Macro pack as well.  In windows it appears to work just fine.  I read it a few pages from the current book (Wheel of Time series) I'm reading to see how it works and it did quite well.  So at the end of this month I will be getting an Oculus Rift, and figured that while wearing it typing in game chat windows would make that a lot easier.  Thought I would try and get things setup before it arrives.  I have no issues typing when I can’t see the keyboard, however the initial orientation of finding the keyboard while effectively blind could be a bit off.  So I figured this would make things more effective.  And it does work a little bit.

I’ve tried 2 games so far (WoW and FFXIV) and they do have same problem, as well as the Steam chat window too.  Once I am in the game WSR still listens to me and I can give it commands and it will follow them.  Like I can say “Open Notepad” and it will tab out of the game and open a Notepad window.  Using the macro tool I can say something like “Action Raise” and it will cast my resurrection spell on my target too.  This was not my intended function, but it is something I think I can eventually get some use out of, so that’s neat. So commands work fine, however it will not take speech dictation at all for some reason.

When I say “enter” it presses enter which does active the chat window and I get a blinking cursor, which is normal.  However if then I follow it up with something like “Hello everyone” then the little WSR window just says “What was that?” as if I was trying to give it a command that it didn’t recognize.  I can pre-program in macros to make canned phrases if I want to, so I can do something like “enter Greeting #1 enter” and it will say “Hello everyone” in my guild chat.  Again handy if there is something I have to type often, especially if it is long.  But nowhere near what I was hoping for.  If I say “enter press h press e press l press l press o enter” then it will do Hello in my guild chat, however that is certainly not effective at all.

I’ve looked around the settings, I’ve even tried running WSR as an administrator as I have had a few other programs that worked better while in games if I did that with no effect.  However I can find no way around this particular issue.  Is there a way around this, or a cause that I can work around.  Are there any other applications that have this similar issue?  After all I noticed that in the Steam chat it does the same thing and that really isn’t any different than google chat (which works fine).

Any tips or setting changes I can make I’ll certainly give it a try.  Thank you for anything that might be helpful.  Also let me know if there is any other information I can provide.  :)


Posted By: mmarkoe_admin
Date Posted: 11/Mar/2016 at 1:17pm
In order for dictation to work the dictation window must be TSF compliant. TSF stands for text services frameworks. It seems apparent that the chat window in these games is not standard. There are two things you can try. First, always make sure to start WSR, windows speech recognition, before any software you wish to dictate within. The other thing you can try is enabling the dictation scratchpad. Do this by right clicking on the microphone icon in the Speech Bar, then select Options and then make sure there's a checkmark next to the Enable dictation scratchpad.

Posted By: Sanjiyan
Date Posted: 11/Mar/2016 at 2:02pm
Thank you.  I do always have WSR running first, I have it run on bootup so that part is covered.  For a few days now I have been trying to run Google searches on this trying to find any either work arounds or even other people posting about the same questions.  I guess it just isn't something that a lot of people have tried to configure.  This is the first time I've come across the term TSF.

When I get home from work tonight I shall certain give this a try, thank you again for the suggestion.  :)

Posted By: Sanjiyan
Date Posted: 11/Mar/2016 at 5:03pm
Well unfortunately that check mark was already on when I got home.  Gave it a few tests with it off and on and same results.  

Posted By: mmarkoe_admin
Date Posted: 12/Mar/2016 at 7:41am
Originally posted by Sanjiyan Sanjiyan wrote:

Well unfortunately that check mark was already on when I got home.  Gave it a few tests with it off and on and same results.

Something you could try is to create a multi-step macro so when you open a chat window:
Step 1 Opens Notepad
Step 2 Pauses for X seconds to allow you to dictate text
Step 3 Copies text dictated
Step 4 Closes Notepad (should take you back to cursor in chat window
Step 5 Paste (Ctrl + v)

If you have programming skills you can do this using WSRMacros. The WSRToolkit allows for multi-step macros.


Posted By: Sanjiyan
Date Posted: 12/Mar/2016 at 9:21am
This does work, I actually did a copy paste test like this a few days ago.  It didn't work very well for me but I also didn't think about making a macro for it which might work out much better.  I will have to give that a try.  I don't have programming skills... But I do know how to.  Programming isn't my favorite thing to do heheh.  But as soon as I see an example of how they work I get it.  I will give that a try.

Posted By: Sanjiyan
Date Posted: 12/Mar/2016 at 11:10am
So while researching the various commands I came across the Prompt command and I have been having success with this macro so far :)  Thank you for pointing me in this direction. 

    <listenFor>Chat Mode</listenFor>
    <waitFor seconds=".1"/>
    <prompt title="Chat Mode" resultState="...">Chat to enter</prompt>
    <waitFor seconds=".1"/>

Posted By: Sanjiyan
Date Posted: 14/Mar/2016 at 9:36am
So after testing this out over the weekend it works fairly well.  Found out it works better in short 1 sentence chucks rather then a longer string of text to input.  Since you cannot correct anything you say, any attempt to correct a word just results in it typing out what you were saying to attempt the correction.  Easier just to cancel and start that sentence over again.  But otherwise it seems to work just fine for what I was trying to get.

Just wanted to say thanks again for helping me get this working.  :)

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.02 -
Copyright ©2001-2019 Web Wiz Ltd. -